Verifone Merchant Orders API is one of 27 APIs that Verifone publishes on the APIs.io network, described by a machine-readable OpenAPI specification.
Tagged areas include Merchant Orders. The published artifact set on APIs.io includes an OpenAPI specification and API documentation.
This API exposes
1 operation
across 1 path,
and defines 98 schemas.
It is described by OpenAPI 3.2.0, at version 2.62.1-SNAPSHOT.
Requests are made against a single base URL, https://api.verifone.com.
The identity and technical contract details declared by the specification.
ExternalOnboarding
object
External merchant onboarding details
3 properties
CancelAdditionalReason
string
Free-Form reason for order cancellation.
InternalAllocatedInformationNewCompanyAndSite
object
Internally allocated identifiers. This is for verifone use only and is subject to change.
EmailAddress
string
A valid internationalized email address, as defined by RFC 5322, RFC 6530, and other RFCs. Due to RFC 5321, an email address can be up to 254 characters long e…
MerchantOrderResponse
5 required
PackageDetails
object
Select the base package, hardware and additional services for this order.
4 properties
1 required
ContactType
object
The details of a Contact.
5 properties
2 required
httpError401
object
The request must be authenticated to access the resource.
4 required
TerminalParameters
object
Deprecated - Please use paymentAppParameters.
4 properties
TimeZone
string
A time zone, following the format defined in the IANA tz database (https://www.iana.org/time-zones). Valid examples are America/NewYork and Etc/UTC. Do not use…
ReplacedDevice
object
A device being replaced under a replacement agreement.
2 properties
2 required
httpError403
object
The request must be authorised to access the resource.
4 required
httpError404
object
The server cannot find the requested resource.
4 required
RequestedDateOfShipment
string
Requested date of shipment.
BundleAndPriceAndData
object
3 properties
1 required
PaymentTypeEnum
string
A type indicator for the payment that is being processed. Value GIFT is deprecated.
MerchantCompanyEntityUid
string
The Verifone allocated unique ID for this merchant company.
CreatedUserId
string
The assigned User ID corresponding to the Order Created By.
ServicePackages
object
5 properties
1 required
httpError504
object
Gateway Timeout Error
4 required
LastChangeTime
string
Time status detailed status last changed.
ThreeDSecureMerchantIdentifiers
object
Override the Merchant ID (merchantId) with the default value configured in the payment provider contract (PPC), where applicable. In cases where the acquirer-i…
2 properties
2 required
MerchantDocument
object
Merchant Document Info.
MerchantContract
object
Used if merchant contract is to be processed
10 properties
BaseAddress
object
An Address following the convention of http://microformats.org/wiki/hcard
10 properties
AltVfiEntityId
string
A friendly ID associated with the merchant site/company. This will be visible/searchable in Verifone central. In many cases this will be the same value as merc…
httpError400
object
The request could not be understood by the server due to malformed syntax.
4 required
BaseOrderData
object
7 properties
2 required
ContractContactType
object
9 properties
2 required
AmountSimple
string
The value, which can be anything from: - An integer. For currencies that are not typically fractional, such as JPY. - A three-place decimal fraction. For curre…
OrderCancellation
object
5 properties
1 required
CustomerOrderLink
object
Customer Order Link Sent Details
8 properties
ErrorResp
object
A common Error object returned as part of the API layer. . This is modified to become the base class for all of the derived HTTP Error Responses.
1 property
1 required
Name
object
An object representing the name or component names of a party, person or business. No elements are mandatory due to the different usages, but the business rule…
6 properties
2 required
ContactAddressType
object
A Contact and their address details.
11 properties
2 required
PrintOptionsEnum
string
Defines the receipt print options. - Possible values are: Never Print - NEVER Prompt for print - PROMPT Always Print - ALWAYS Always Print when Signature is Ca…
UserName
string
The username of the person who's UID is represented, e.g. "John/Jane Smith".
EntityUid
string
The Verifone allocated unique id for this site.
PostCode
string
Identifier consisting of a group of letters and/or numbers that is added to a postal address to assist the sorting of mail.
CountryCode3Enum
string
The [ISO 3166-1 alpha-3](https://en.wikipedia.org/wiki/ISO3166-1alpha-3) country code. Note: The country code for Great Britain is GB and not UK as is used in…
Phone
object
A simple Phone Number
5 properties
2 required
VariableResponseType
object
Variable/Value Pairs.
2 properties
PaymentDetails
object
Details of how the order will be paid, and the further re-occuring billing for services.
1 property
1 required
IBANIdentifier
string
International Bank Account Number (ISO 13616-1:2007). The use of an IBAN is mandated for all SEPA transactions. There are 66 countries that support this format…
Notification
object
Object containing the sent date-time and template used for the notification.
3 properties
Industry
string
The Industry type applicable to a Merchant.
BaseProcessorParameters
object
Payment Processor Parameters related to Merchant onboarding.
2 properties
1 required
TransactionLimits
object
5 properties
DocumentStatusEnum
string
Current status of the document. Rejected documents must be re-uploaded.
MerchantOrder
object
1 required
SignersInformation
object
Information on the signers in the request.
5 properties
1 required
VmssSchemeStatus
string
Scheme Status
AdjustedPriceType
object
2 properties
CardProductSurcharge
object
Surcharging settings
8 properties
3 required
httpError500
object
Unexpected Server Error
4 required
NotificationReminder
object
Notification Reminder Sent Details
4 properties
OrderId
string
Verifone allocated ID for the Order.
EntityUidDeprecated
string
The Verifone allocated unique id for this site. This is allocated by Verifone when an order is initially received. Please use value returned in OrderResponse.
CancelReasonEnum
string
Reason for order cancellation.
ContentTypeEnum
string
Supported content type for documents.
CurrencyCodeEnum
string
Three-letter ISO 4217 alphabetical currency code. e.g. USD. Values correspond to [ISO 4217](https://wikipedia.org/wiki/ISO4217). Deprecated: BYR (replaced by B…
VmssSchemeMatches
number
Number of matches found against the VMSS service.
SigningInformation
object
Information on the signing request.
4 properties
2 required
VmssApplication
object
5 properties
AddressWithoutType
object
An Address following the convention of http://microformats.org/wiki/hcard
4 required
RequiredDocument
object
Merchant Required Document Details
7 properties
4 required
BICIdentifier
string
International Bank Identifier Code Format. The Bank Identifier Code or SWIFT Code ,this can also be referred to as the CHIPS, NCC, VSC or IFSC depending on you…
PhoneTypeEnum
string
Phone type in PHONETYPECON. Mapped to PARTYPHONE.PHONETYPECONID or VENUEPHONE.PHONETYPECONID
httpError429
object
The resource exists the number of requests has exceeded the specified quota.
4 required
NotificationReminders
object
A container for all supported notification reminders.
3 properties
ContactTypeEnum
string
An indicator for the type of contact. |Value|Description| |----|-----------| |BUSINESS|Generic business contact information, e.g. info@example.com| |DISPUTEHAN…
SepaAccount
A SEPA Account structure extending the base account
DomesticAccount
A Domestic Bank Account structure extending the base account.
MCC
string
The Merchant Category Code (MCC). A 4 digit Code classifying the type of business being done by the card acceptor or Merchant (in accordance with ISO 18245).
OrderStats
object
Order Statistics
2 properties
MerchantName
string
The primary merchant name, e.g. "McDonalds".
ReplacementAgreement
object
Replacement agreement details for devices covered under this contract.
2 properties
1 required
DomesticSettlementAccount
ExtendedDetails
object
Detailed Status of the Order
5 properties
Account
object
Unambiguous identification of an account to which credit and debit entries are made. These entries are based on the Open Banking standards used in various coun…
4 properties
SettlementDetails
object
Settlement details needed for onboarding in certain situations e.g. for Payware solutions.
1 property
InternalAllocatedInformation
object
Internally allocated identifiers. This is for verifone use only and is subject to change.
15 properties
BaseMerchant
object
details of the merchant
19 properties
5 required
PaymentAppParameters
object
Payment Parameters - these can be specified per merchant and/or overridden at the poi level. If no values are specified then default template values will be ap…
79 properties
OrderReference
string
Client reference for the Order.
ReceiptOptions
object
Receipt Options
6 properties
PackageBundleId
string
The Verifone allocated ID for the package bundle.
BundleAndPrice
object
2 properties
1 required
httpError503
object
Service Unavailable Error
4 required
DetailedStatusEnum
string
An order will be in one of the following states.
BaseRegionalParameters
object
Payment Parameters - Regional specific options
1 property
TipOptions
object
Tip Options
3 properties
TransactionOptions
object
12 properties
BaseAddressWithoutType
object
An Address following the convention of http://microformats.org/wiki/hcard
5 properties
The full machine-readable OpenAPI contract behind this narrative.
Other APIs Verifone publishes across the network.